64bit Linux still not working?


#1

Hi there @glitchpop, @atom2626, and others,

This is a re-do of your thread regarding using the Muse SDK on 64bit Linux. I accidentally deleted the original thread while attempting to delete a single irrelevant post within it. Terribly sorry about that! There doesn’t seem to be any way to easily restore the thread, so I’m restarting it here.

[B]To address one of the main questions previously posed:[/B]

There is not a 64bit Linux build of the Muse SDK right now. We don’t officially support 64bit Linux.

However, it may be possible to get it working by installing the correct dependencies yourself. To quote from a previous thread on the subject:

However, personally I’ve managed to get muse-io working on Ubuntu 64bit just by installing the correct 32bit dependencies. IIRC, I just used apt and installed:

  • zlib1g:i386
  • libc6-dev-i386
  • lib32stdc++6-4.7-dev
  • libbluetooth-dev:i386

This is on a small headless machine using a CSR Bluetooth 4.0 dongle for the Bluetooth connection, by the way. That may not be relevant, but I just thought I would mention it.

Apologies again for the deletion!


#2

My partner Ron just work out the way to do it. Check out his blog.

http://atlantsembedded.com/b/getting-muse-sdk-work-linux


#3

I’m really annoyed the old thread was deleted because I’m having trouble pairing my Muse again, on Ubuntu 32bit this time, and that old thread was the only place that actually had correct documented process for troubleshooting all the issues and getting it to work. Currently the Muse is showing up in my list of Bluetooth devices but when I run MuseLab it won’t let me connect to a port - just nothing happens.


#4

sounds great, do you have a link that currently works? the atlantsembedded one seems to be dead.