Cannot connect from a Windows Machine


#1

I am successfully able to connect to Muse using iPhone Calm app.

From my Windows system, I can add the Muse as a Bluetooth device. So the bluetooth pairing is ok.
But, muse-io.exe is not able to connect.
Using
>> muse-io verbose
I get the following error

  No device specified, connecting to any paired and available Muse.

  Device match pattern: muse
  Connecting to paired device "Muse": n/a
  failed to open rfcomm channel, read thread not started

It keeps retrying after this. Any thoughts on how to proceed?

thanks for any help.


#2

Hi Anika,

Based on answers I have seen on other threads, I understood that the Muse device holds internally the last connected device and since you have already connected it to iPhone it will not connect to others unless you do factory reset to release the previously paired devices.

From OFF state, press and hold the power button for 15 seconds (some leds start flashing after 4 seconds, but keep holding until 15 seconds). It will turn off again.
Them start from begining. Add to Windows, pair it, and it should connect after running muse-io again.

Hope this helps, others will correct me if I’m wrong.

Good luck!

Eduardo


#3

I actually had already done this. I had to do the reset just to do the pairing from Windows ‘Add a Bluetooth Device’ screen,
It paired after the reset (holding power button for 15 seconds), but the muse-io.exe does not work. I still see the errors that I listed before.

thanks,
-Anika


#4

Hi Anika, what version of windows are you running?

Just to be a paranoid trouble shooter could you:

  • Disconnect other Bluetooth devices that are connected.

  • After you’ve paired the Muse and your windows computer says “drivers installed”, reboot the computer

  • Once it’s paired, try to connect as you did before. It may take a few tries, depending on the default inquiry and scan times for your bluetooth hardware. Ensure the Muse is physically close to your computer.

An additional sanity check can use the Muse’s standard com port profile exposed over bluetooth. Any program that is designed to open a com port should be able to open the Muse’s com port over bluetooth (e.g. putty, hyperterminal) if the bluetooth radio and hardware are compatible (they should generally be). If a connection can be made in this manner it can be made with muse-io. Once connected to the com port with a serial terminal enter “v” and a “return” to the com port to get a human readable response. If it cannot connect this way (with another terminal program to the newly created com port) it may be a hardware problem.


#5

Thanks Matt for your reply, the tip certainly helped. I am still not sure if I understand the problem, but I have a guess.
I think my pairing was never getting completed despite of multiple tries. The LEDs never went solid, they stayed blinking. And therefore Muse-IO would not work.
However, when I tried the Terminal window and types the command ‘v’, suddenly the LEDs turned solid, and the pairing completed.
So my guess is that most people may be trying the terminal window first, and it was working. It would be good for some other people to try on Windows without ever starting the terminal window.
Thanks for your help. I am up and running now.


#6

My device was not paired completely. I got some seconds of connection then it dropped. Tried Anika’s answer on cmd.exe:

\Muse>muse-io v

and now my Muse is paired with five solid lights and receiving EEG data.

Thanks Anika.


#7

Hi all, i have connected muse device by the command “muse-io --com 22” in my windows 7. It’s getting paired. But the problem is when i type command “muse-io --device Muse” it still says

"No device specified, connecting to any paired and available Muse.
Device match pattern: muse
Connecting to paired device 'muse’
connection failure "

please help me with the failure.


#8

I have a similar problem, but I created a new thread because it is slightly different. It’s posted here:

http://forum.choosemuse.com/forum/technical-support/5802-more-muse-connection-problems


#9

In this case you might find it easier to not specify --device or --com-num. If muse-io is not given a com port or a device it will just try connecting to each device on your system until it succeeds.


#10

Hi all,

I know if you do not have a bleutooth version 4, it can have some problems to connect even it is paired with the OS. We have tested it on bleutooth version 2 on a Windows 7 and had problems. We added a dongle bleutooth version 4 and worked directly with pairing and the connection.