Can't convert a file (utf8 issue)


#1

I recorded with Muse-Lab(.Muse format)
I want to open a file and read it.
I want to convert .muse to .txt or .csv
But I couldn’t open and convert some files.
It says ‘utf8’ codec can’t decode.
In the same recording condition, other files worked well.
What should I do? Need to re-recording?


#2

These files look corrupt to me.

If you open them in notepad, you can see many lines of “normal” looking data which look like this:

=/muse/eeg fffff 846.9597 846.1539 852.1978 865.4945 1025.8608
Q	L7)îœEÖA¢C
?/muse/eeg fffff 853.00366 854.61536 855.42126 800.6227 743.4066
O	L7)îœEÖA¢A

But then there are sections with many lines of unintelligible text, e.g:

Gô°´idX¾²rüaW-òõ/7BIô2JîŸòTE™†ã,K]/ôãâñ‡„N`®§]Õ€¯vŸ×‡¦°cÀŸ§Ÿ)ÞÞÓõËɹ–ͧ7›^™÷X쓆+€Jœ(ê-_ùô÷놐XUZ•±.^×»šx·ñtÜîËFeeÇôÍ_ŸsoÉòdȖ̧Œ0€ô˜6œ†RE›\ûšD+€èè3š„ƒ![ôT7é67„ÐÊR¹vÎœ¬™ÐZ±£wñ§ì3bó{— ̍\€3Yì™ó,@\ñæ-õöF10ì0™@Wð„“@ž/¡•°Ô¨Ýž 1±ÈC¦-è¬ß¨Ÿd{L½fa½àù€/^‚Z6,Zû94ìX2ŽîöúU/阛ôVS_óé+T€&㜘/0Y“óóÊhzÿ¿m¢+ŪB½êÑalñË–5®cô¸Ò¦V|Ö{ºQTò2ë‚_þ@L#õ(5õ1ó1Ž‡ðƒZ‚˜G;Tî(í]ƒá,ž\þAY²”ey1i·ƒ»A×

I’ve not seen that before in a .muse file, so I think yours must be corrupt.

Note that Interaxon’s research tools don’t properly support characters outside of the standard ASCII alphabet, for example accented letters like “é”, and kanji will likely cause problems.

The parsing error in your screenshot states that the error is in the annotation data, so the only thing I can think of is that you entered a large section of text with non-ASCII characters and maybe Muse Lab saved this incorrectly.


#3

Hello, Enigma.
Nice to see you again. I appreciate your kind answer.

I opened my bad files with notepad. There were dirty lines.
Ok then. I will redo the recording.
But what make it to be corrupt? How can I prevent it happen again?

I only used Muse - MuseMonitor(iOS) - MuseLab.
The data that I uploaded was recorded in MuseLab. I just clicked “record” botton and It was it.
I have no idea where the “large section of text” comes from.
It happened 4 out of 10 data set.
It’s a big issue for me. The recording system seems not stable.


#4

What kind of annotations did you add while recording? Are you using markers? What are their osc paths?

Rather than streaming to Muse Lab, you can just record directly with Muse Monitor. This will assure you get a clean recording.

If you need to have markers, Muse Monitor has this option, scroll to the bottom of settings and you will see “Advanced Settings” -> “Marker buttons”. This will give you five numbered buttons to inject data in to the recorded/streamed data.


#5

Well. I didn’t use any annotation at all.
Actually clean/dirty data were recorded in same condition. Just participant was different.
Does bad signal could cause this?

Without Using muselab, it is hard for me to sync with computer stimulus. Any tip with your app? I just want to start recording as stimulus are given.

You mentioned marker in your app. How does it work? I mean, What happens to data? How can I find where I put markers in data? I tried before, I guessed that it just makes blank line?


#6

The marker buttons create an OSC event in the data stream. If you create a CSV rather than Muse format, you will see the marker path in the last column,