Difficulties with Muse Player


#1

Hello,

I am having some difficulties with installation of muse-player. After installing the SDK v2.2 (mac) and following the steps to install python, liblo, pyliblo, google protocol buffer, and SciPy, I continue to receive the following:
[SIZE=11px]File “/Applications/Muse/muse-player”, line 4, in <module>[/SIZE]
[SIZE=11px] from input_handler import *[/SIZE]
[SIZE=11px] File “/Applications/Muse/input_handler.py”, line 1, in <module>[/SIZE]
[SIZE=11px] import liblo[/SIZE]
[SIZE=11px]ImportError: No module named liblo

Can you please advise me in finding a solution?

Thank You.[/SIZE]


#2

pip install pyliblo


#3

I must have missed something. I still get the error after installing liblo and pyliblo.
*Note, that pip install pyliblo failed getting the following error: Downloading/unpacking pyliblo
Could not find any downloads that satisfy the requirement pyliblo
Some externally hosted files were ignored (use --allow-external pyliblo to allow).
Cleaning up…
No distributions at all found for pyliblo

So, went the build install way

My-MacBook-Pro-2:pyliblo-0.9.1 myadmin ./setup.py build
… My-MacBook-Pro-2:pyliblo-0.9.1 myadmin ./setup.py install
running install
running build
running build_ext
running build_scripts
copying and adjusting scripts/send_osc.py -> build/scripts-2.7
copying and adjusting scripts/dump_osc.py -> build/scripts-2.7
changing mode of build/scripts-2.7/send_osc.py from 644 to 755
changing mode of build/scripts-2.7/dump_osc.py from 644 to 755
renaming build/scripts-2.7/send_osc.py -> build/scripts-2.7/send_osc
renaming build/scripts-2.7/dump_osc.py -> build/scripts-2.7/dump_osc
running install_lib
copying build/lib.macosx-10.6-intel-2.7/liblo.so -> /Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages
running install_scripts
copying build/scripts-2.7/dump_osc -> /Library/Frameworks/Python.framework/Versions/2.7/bin
copying build/scripts-2.7/send_osc -> /Library/Frameworks/Python.framework/Versions/2.7/bin
changing mode of /Library/Frameworks/Python.framework/Versions/2.7/bin/dump_osc to 755
changing mode of /Library/Frameworks/Python.framework/Versions/2.7/bin/send_osc to 755
running install_data
copying scripts/send_osc.1 -> /Library/Frameworks/Python.framework/Versions/2.7/share/man/man1
copying scripts/dump_osc.1 -> /Library/Frameworks/Python.framework/Versions/2.7/share/man/man1
running install_egg_info
Writing /Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pyliblo-0.9.1-py2.7.egg-info

My-MacBook-Pro-2:pyliblo-0.9.1 myuser$ muse-player /Applications/Muse/recordings/muselab_recording.muse
Traceback (most recent call last):
File “/Applications/Muse/muse-player”, line 4, in <module>
from input_handler import *
File “/Applications/Muse/input_handler.py”, line 1, in <module>
import liblo
ImportError: No module named liblo


#4

What is the output of python --version? Is your default python 2.7? What does the output of “which python” show for your python location?


#5

2.7.8 /Library/Frameworks/Python.framework/Versions/2.7/Resources/Python.app/Contents/MacOS/Python


#6

I get the same error. Python 2.7, but ‘no module named liblo’. Can anyone advise, please?


#7

https://sites.google.com/a/interaxon.ca/muse-developer-site/download/macos-install---sdk-v2-2

Did you uninstall any previous version of liblo (step 2.2)

What happened when you installed liblo? (Step 2.3)


#8

sbwoodside I get the same error as warpenator, even when following your suggestion (step 2.2 and 2.3). Any ideas?


#9

Hi Muse Developers

Same problem here as other people? Could you reply a suggestion, please???

Regards

Sean
[SIZE=11px]Traceback (most recent call last):[/SIZE]
[SIZE=11px]File “/Applications/Muse/muse-player”, line 4, in <module>[/SIZE]
[SIZE=11px]from input_handler import *[/SIZE]
[SIZE=11px]File “/Applications/Muse/input_handler.py”, line 1, in <module>[/SIZE]
[SIZE=11px]import liblo[/SIZE]
[SIZE=11px]ImportError: No module named liblo[/SIZE]


#10

Make sure that your .bash_profile (in your home directory) contains these lines export
PATH="$PATH:/Applications/Muse"
[SIZE=13px]export C_INCLUDE_PATH=/usr/include[/SIZE]
[SIZE=13px]export LIBRARY_PATH=/usr/lib[/SIZE]
[SIZE=13px]export DYLD_LIBRARY_PATH="$DYLD_LIBRARY_PATH:/Applications/Muse"

Once you add these lines, close the Terminal and open a new one.[/SIZE]

FYI, In the pyliblo step, the PATH variables are WRONG. There is no /usr/local directory by default on Mac OS X, so nothing will be found at these paths.

Hopefully this will get you farther along. I have never gotten past the pyliblo step. There is another error that I can’t resolve posted below.

–tom


#11

FYI, default Python 2.7.5 is default on Mac OS X 10.9.5. It’s not clear if an upgrade to 2.7.8 is necessary.

This is the error that I get when trying to build pyliblo :

building ‘liblo’ extension
cc -fno-strict-aliasing -fno-common -dynamic -arch x86_64 -arch i386 -g -Os -pipe -fno-common -fno-strict-aliasing -fwrapv -DENABLE_DTRACE -DMACOSX -DNDEBUG -Wall -Wstrict-prototypes -Wshorten-64-to-32 -DNDEBUG -g -fwrapv -Os -Wall -Wstrict-prototypes -DENABLE_DTRACE -arch x86_64 -arch i386 -pipe -I/System/Library/Frameworks/Python.framework/Versions/2.7/include/python2.7 -c src/liblo.c -o build/temp.macosx-10.9-intel-2.7/src/liblo.o -fno-strict-aliasing -Werror-implicit-function-declaration -Wfatal-errors
[B]src/liblo.c:314:10: [/B][B]fatal error: [/B][B]‘lo/lo.h’ file not found[/B]
#include “lo/lo.h”
[B]^[/B]
[SIZE=13px]1 error generated.[/SIZE]
[SIZE=13px]error: command ‘cc’ failed with exit status 1[/SIZE]
toms-mbp:pyliblo-0.9.2


#12

I face this problem too. I tried everything possible. Has anybody found a fix?


#13

[SIZE=12px]For the error, [‘lo/lo.h’ file not found]

  1. in terminal, set the current directory to be the folder where pyblio is downloaded
  2. enter the following line.[/SIZE]

[SIZE=12px]C_INCLUDE_PATH=/usr/local/include LIBRARY_PATH=/usr/local/lib python setup.py install[/SIZE]

(Source: http://nuigroup.com/forums/viewthread/2584/#16315)


#14

Hi yhbumjin,

This thread is out-of-date. The Muse SDK has been packaged in an all-in-one installer since 3.0.1 came out in November (as of this writing we’re on 3.4.1). You shouldn’t have to install any dependencies to run muse-player any more with the latest version of the SDK. Make sure you’ve downloaded the latest version from developer.choosemuse.com, uninstall the old one, and install the new one.


#15

I had this same issue just recently, was able to fix it by using Homebrew to install the liblo package then “pip install pyliblo” worked perfectly!