Disable EEG data Compression


#1

Connecting drictly to Muse without MuseIO, Is there a Serial Command to disable EEG data compression?

There is no need for it in scenarios without the limit to 6kbps bandwidth


#2

Hi David,

So, are you really giving a try to the MCP (Muse Communication Protocol) ? You’ll be the first … good luck !

Again, trying to guess (since if some of the team members will come to answer, it will take some weeks)

  • there are so few serial commands, and except for the “choose notch frequency”, none of the others deal with such a low level setting,
  • I believe that the compression setting is one of the bits of the presets available
  • but there is no documentation about the composition of the presets bytes, so … just on a trial and error approach …

Maybe the fourth bit of the lower nibble of the preset byte, since it’s allways “zero” for the consumer Muse (all four presets available set compression “ON”),
and this same bit is allways “one” for the research Muse (where all presets sets compression “OFF”).
But, maybe also any of the bits of the upper nibble, as this nibble is allways “1” for the consumer and “A” for the research.

I tried, sending --preset (18 for 10), (1A for 12), (1C for 14) and (1D for 15), but Muse-IO allways give a warning message “invalid preset” and loads the last preset used,
but certainly this is being trapped by muse-io itself and not from the Muse device.


#3

Thanks Eduardo, the basics are working, and half the compression part, but there is no need for it for non ios devices.

The Research Firmaware presets seems to include non compressed data and more sampling speed, will be good to have them too.

The consummer the presets worked too via MCP, but none is non compressed.


#4

Hi guys,

Unfortunately on the Consumer version of the firmware you can not turn compression off. Although I agree that it is not required for none iOS connections which do not suffer from a limitation on the data bandwidth.

There is also no secret flags to discover in the preset mapping. All the available presets map 1 to 1 to certain configurations within the firmware.

As such you’re, unfortunately, going to need to get the compression parsing functioning if you wish to connect through this method.

I’m glad to hear you’re having success with the implementation.


#5

Thanks Farough, how can we get the Reseach firmware?


#6

I have the same question: how can I get the Research firmware?:slight_smile: