Disable Muse Direct Updates on Windows 10


#1

I am working on an installation that needs to boot automatically at the beginning of the day (Windows 10). Currently, this does not work because when I boot the machine, Muse Direct starts checking for updates but because the machine is not connected to the internet (and never will be) it never finds the updates and does not start properly.

I have completely disabled Windows updates and the services that restart the update search (this is a computer that will never be connected to the internet! We don’t need updates!). The update service is completely off. I’ve also turned off automatic app updates from the store.

I need to either A) Get Muse Direct to stop looking for updates. Again, this is a computer that will never be connected to the internet so we are not concerned about viruses. or B) Find some other way of reading the headset data and sending it over osc to our app. Is there any other way to do this without a separate linux machine?


#2

https://MuseMonitor.com for Android or iOS supports OSC, but you’d need to run that on a phone connected to the same WiFi network (assuming you have one).


#4

Well that’s not good! I just checked for crash reports on Apple’s developer site and I’m seeing Zero crash reports, so don’t think it’s a problem with Muse Monitor I’m afraid.

I’ve tested Muse Monitor up to iOS 12 (as of Oct 2018), so v11 should be fine.

  • I’d recommend that you re-install Muse Monitor in-case the download was corrupted.
  • Check that your iPad has some free space, because that can cause a lot of apps to have problems. To check this go to Settings > General > About, then under Capacity, you will see Available.
  • Restart the iPad, this fixes a bunch of stuff on most devices :wink:

If it’s still not working, email me Support@MuseMonitor.com and I’ll see what I can do.


#5

Wait what happened to the original issue? So is it really not possible to get Muse Direct to stop looking for updates when it starts and there’s no other app that will do the same thing for Windows?


#6

Sorry, I assumed you guys were on the same team.

Have you tried turning off app updates from the Microsoft Store app? Store > […] > App Updates


#7

Yeah I went through a lot of hoops to disable windows 10 updates and also disabled updates from the store through the store settings but it still spends 2-3 minutes looking for updates before eventually giving up.

My work around right now is to have all the other start up stuff wait 400 seconds before continuing. That makes sure that Muse Direct has given up on looking for updates. It basically works but that means that 1) it takes about 7 minutes to start up. and 2) The timeout for looking for updates seems slightly variable so while 400 seconds is more than enough time right now, I am a little concerned that it could slow down in the future and stop working.


#8

You’re right. I can’t see any way to stop it checking for updates.

What about never closing Muse Direct? You can enable hibernation support, and hibernate instead of powering down.

On Windows 10 you can find hibernate in control panel here: Control Panel > Power Options > Choose what the Power button does. Then in the drop down list select hibernate.

Hibernate saves all active RAM memory to disk, so when you power back up, everything is restored to it’s previous state. None of your apps will get closed when hibernating, so Muse Direct will already be running and won’t need to check for updates.