Downsampling in muse-player?


#1

I recived data from muse-player like this: [TABLE]
[TR]
[TD]1415880351.816000[/TD]
[TD]/muse/eeg[/TD]
[TD]1579.18115234[/TD]
[TD]261.551879883[/TD]
[TD]419.470001221[/TD]
[TD]1579.18115234[/TD]
[TD]1415880343[/TD]
[TD]339698[/TD]
[/TR]
[TR]
[TD]1415880351.817000[/TD]
[TD]/muse/eeg[/TD]
[TD]1158.06616211[/TD]
[TD]366.830627441[/TD]
[TD]419.470001221[/TD]
[TD]1158.06616211[/TD]
[TD]1415880343[/TD]
[TD]339698[/TD]
[/TR]
[TR]
[TD]1415880351.817000[/TD]
[TD]/muse/eeg[/TD]
[TD]210.557479858[/TD]
[TD]1524.89672852[/TD]
[TD]1472.25744629[/TD]
[TD]105.278739929[/TD]
[TD]1415880343[/TD]
[TD]339698[/TD]
[/TR]
[TR]
[TD]1415880351.818000[/TD]
[TD]/muse/eeg[/TD]
[TD]526.393737793[/TD]
[TD]1524.89672852[/TD]
[TD]1472.25744629[/TD]
[TD]526.393737793[/TD]
[TD]1415880343[/TD]
[TD]339698[/TD]
[/TR]
[TR]
[TD]1415880351.818000[/TD]
[TD]/muse/eeg[/TD]
[TD]1368.62365723[/TD]
[TD]472.109344482[/TD]
[TD]419.470001221[/TD]
[TD]1263.34484863[/TD]
[TD]1415880343[/TD]
[TD]339698[/TD]
[/TR]
[TR]
[TD]1415880351.818000[/TD]
[TD]/muse/eeg[/TD]
[TD]1368.62365723[/TD]
[TD]261.551879883[/TD]
[TD]208.912506104[/TD]
[TD]1263.34484863[/TD]
[TD]1415880343[/TD]
[TD]339698[/TD]
[/TR]
[TR]
[TD]1415880351.819000[/TD]
[TD]/muse/eeg[/TD]
[TD]315.836212158[/TD]
[TD]998.503051758[/TD]
[TD]840.584960938[/TD]
[TD]210.557479858[/TD]
[TD]1415880343[/TD]
[TD]339698[/TD]
[/TR]
[/TABLE]

First column is described as “timestamp”, so we could see that signal is sampling very often. It is possible to add downsampling as parameter in muse-io or muse-player? Or I should do it in Matlab? Or maybe I do something wrong?
I type in terminal:
muse-io.exe --50hz --osc-timestamp --osc osc.tcp://localhost:5001’
and
muse-player.py -l 5001 -C muse.csv

Thanks for any help


#2

Hi there,

Muse-IO and Muse-Player don’t have downsampling options. The easiest thing for you to do is to downsample in whatever software you are receiving the data in, which sounds like MATLAB in your case.