Error on Macbook


#1

Whenever I try to enter the command
muse-io --device musename

in the terminal I get this error
dyld: Library not loaded: /usr/local/lib/liblo.7.dylib
Referenced from: /Applications/Muse/muse-io
Reason: Incompatible library version: muse-io requires version 10.0.0 or later, but liblo.7.dylib provides version 8.0.0

I previous thread about a similar error did not help
http://forum.choosemuse.com/forum/technical-support/5230-museio-dyld-library-not-loaded-usr-local-lib-liblo-7-dylib-error

Please help?


#2

Do you already have liblo installed for some reason? Also, what shell program are you using?


#3

I might have installed it multiple times…
I am using terminal


#4

What is the output of these commands:

echo $PATH
echo $DLYD_LIBRARY_PATH
echo $DYLD_FALLBACK_LIBRARY_PATH

?

Is there a line in your ~/.bashrc file adding /Applications/Muse to your PATH?


#5

Here are my results
echo $PATH
/Library/Frameworks/Python.framework/Versions/2.7/bin:/Applications/Pm2:/Applications/SuperVP:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/Library/TeX/texbin:/Applications/Muse

(this looks really wrong)

echo $DLYD_LIBRARY_PATH
nothing!

echo $DYLD_FALLBACK_LIBRARY_PATH
:/Applications/Muse

Sorry I am not sure how to use ~/.bashrc Thanks for the help!


#6

Hm, that all looks fine to me, actually. If you’ve separately installed liblo, try uninstalling it and see if that helps.