Forcing preset "14" required for DSP input


#1

Hi Developers

I recently found a small issue when I use the muse-io --preset command.

the program forcing the preset to 14, no matter what i specified. Please see below.

Does anyone have the same issue?

Regards
Sean
[SIZE=11px]$ muse-io --preset 12 --osc osc.udp://localhost:5004[/SIZE]

[SIZE=11px]muse-io 3.6.5 (Build-21 Jan 30 2015 20:12:18)[/SIZE]

[SIZE=11px]OSC messages will be emitted over OSC to paths: [/SIZE]
[SIZE=11px]/muse/eeg[/SIZE]
[SIZE=11px]/muse/eeg/quantization[/SIZE]
[SIZE=11px]/muse/acc[/SIZE]
[SIZE=11px]/muse/version[/SIZE]
[SIZE=11px]/muse/config[/SIZE]
[SIZE=11px]/muse/batt[/SIZE]
[SIZE=11px]/muse/drlref[/SIZE]
[SIZE=11px]/muse/elements[/SIZE]

[SIZE=11px]to OSC URL:[/SIZE]
[SIZE=11px]osc.udp://localhost:5004[/SIZE]
[SIZE=11px]Forcing preset “14” required for DSP input.[/SIZE]

[SIZE=11px]No device specified, connecting to any paired and available Muse.[/SIZE]

[SIZE=11px]Device match pattern: muse[/SIZE]
[SIZE=11px]Connecting to paired device “Muse”: open! [/SIZE]
[SIZE=11px]Connected. [/SIZE]

[SIZE=11px]================== Muse Status ==================[/SIZE]
[SIZE=11px]Muse Hardware: 15.0.0[/SIZE]
[SIZE=11px]Muse Firmware: 7.2.4[/SIZE]
[SIZE=11px]Muse Firmware type: Consumer[/SIZE]
[SIZE=11px]Muse Bootloader: 7.2.4[/SIZE]
[SIZE=11px]Build No: 44[/SIZE]
[SIZE=11px]BT Mac Address: 000666A06B0E[/SIZE]
[SIZE=11px]BT Firmware: Ver 5.45 IAP 10[/SIZE]
[SIZE=11px]Serial: 1150-W8NL-6B0E[/SIZE]
[SIZE=11px]Preset: 14[/SIZE]
[SIZE=11px]Filters Enabled: true[/SIZE]
[SIZE=11px]- Notch Frequency: 60Hz[/SIZE]
[SIZE=11px]Accelerometer Enabled: true[/SIZE]
[SIZE=11px]EEG Sample Frequency: 3520Hz[/SIZE]
[SIZE=11px]EEG Output Frequency: 220Hz[/SIZE]
[SIZE=11px]EEG Samples Bitwidth: 10[/SIZE]
[SIZE=11px]EEG Channel Count: 4[/SIZE]
[SIZE=11px]EEG Channel Layout: TP9 FP1 FP2 TP10 [/SIZE]
[SIZE=11px]Downsampling: 16[/SIZE]
[SIZE=11px]Output Mode: SEROUT_COMPRESS[/SIZE]
[SIZE=11px]=================================================[/SIZE]

[SIZE=11px]bits/second: [B]8166[/B] receiving at: [B]225.91Hz [/B] dropped samples: [B]0[/B][/SIZE]
[SIZE=11px]Battery: [B][================== ]+ 91%[/B] voltage: [B]4.07mV[/B][/SIZE]
[SIZE=11px]Noise: [ [B]4.5% 12.5% 12.5% 17.1% [/B] ]^C[/SIZE]


#2

I’m having the same issue, have you found a solution yet?


#3

unfortunately, i didn’t. it doesn’t make difference for me to use 14 or 10 or 12. But, I still hope someone can point out whats wrong with it. cheers


#4

Hi guys. I found that using the command “–no-dsp” and then the preset command lets you change your preset. However, this will disable all the “Muse elements” data, including the horseshoe indicator, alpha power and so on. Pretty weird.