Help with recording a MuseLab session


#1

I fall into one of those categories where I’m not able to get MuseLab running on my machine. While I can use the MuseMonitor app and James’ script to produce the Excel Graph… Can anyone assist me in taking my data, running it through the MusePlayer playback function. Capture it to video so that I may review it as part of my research project?


#2

If you want to record a live video of Muse Monitor in action, then I can highly recommend Reflector 2 by Air Squirrels, this software enables you to have your mobile device screen on your Mac/PC and record the result.

Specifically regarding MusePlayer playback, if you’re having problems with using the command line, below is a batch file script, so you can just drag and drop a file on to it, to run.

Set musepath=C:\Program Files (x86)\Muse\
"%musePath%muse-player.exe" -q -v -f %1 -s osc.udp://localhost:5000

Save the above in a file called RunMusePlayer.BAT and the you can just drag and drop Muse format recordings on to it to start it streaming to Muse Lab.
Note that on older Windows machines, the Path to your Muse install may be C:\Program Files\Muse without the (x86) bit.


#3

Thanks James, I’ll check out the Reflector software… my issues with the Muse Player isn’t so much the command line… I can see the streaming data fine, just not the graph window to the right… mine just flickers. I’ve tried everything. So it’s my system somehow not compatible. I’ll look into the software you mentioned… Thanks again!


#4

What OS are you running? Have you tried updating your graphics driver?

If you want a really crazy workaround, you could run Muse Lab in a VirtualBox virtual machine and that’d likely bypass any graphics card errors and you’d be able to record it! :wink:


#5

I’ve thought of it… and even downloaded the Linux and was going to attempt to run it from a USB harddrive, but that’s so much more learning curve for me and almost not worth it at this point. I’m on a Dell desktop running the Windows 7… everything is cost, cost, cost to make it work right… and I’m just not at that point to upgrade. Perhaps at another time when I have a better system. I have upgraded all the drivers hoping that would solve it… but it didn’t.


#6

My next step is to simply… setup my webcam on a tripod to record my android phone running your app… during my meditation/hypnosis sessions and simply add that as one of my steps required for the research.