Issues running MuseLab and muse-io


#1

So the install on Ubuntu 14.04 seemed to work but MuseLab and muse-io will not run. I’ve started this as a new thread since it’s more of a support issue than a dev issue and I have had no response from any Muse people on the other thread.

Here is what I’m getting when I try to run muse-io:
[I]muse-io: error while loading shared libraries: libbluetooth.so.3: cannot open shared object file: No such file [/I]or directory

and when I run MuseLab:
[I]Exception in thread “main” java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.jdt.internal.jarinjarloader.JarRsrcLoader.main(JarRsrcLoader.java:58)
Caused by: java.lang.UnsatisfiedLinkError: /home/research/Muse/java/lib/i386/xawt/libmawt.so: libXtst.so.6: cannot open shared object file: No such file or directory
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary1(Unknown Source)
at java.lang.ClassLoader.loadLibrary0(Unknown Source)
at java.lang.ClassLoader.loadLibrary(Unknown Source)
at java.lang.Runtime.load0(Unknown Source)
at java.lang.System.load(Unknown Source)
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary1(Unknown Source)
at java.lang.ClassLoader.loadLibrary0(Unknown Source)
at java.lang.ClassLoader.loadLibrary(Unknown Source)
at java.lang.Runtime.loadLibrary0(Unknown Source)
at java.lang.System.loadLibrary(Unknown Source)
at sun.security.action.LoadLibraryAction.run(Unknown Source)
at sun.security.action.LoadLibraryAction.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Toolkit.loadLibraries(Unknown Source)
at java.awt.Toolkit.<clinit>(Unknown Source)
at java.awt.EventQueue.invokeLater(Unknown Source)
at javax.swing.SwingUtilities.invokeLater(Unknown Source)
at ix.graphs.SignalVisualizerApp.run(SignalVisualizerApp.java:196)
at ix.graphs.SignalVisualizerApp.main(SignalVisualizerApp.java:185)
… 5 more[/I]

I found this general thread about lib conflicts so maybe it applies my system is also 64 bit http://ubuntuforums.org/showthread.php?t=2088175

Any help would be appreciated thanks


#2

Hey we’re working on a better linking scheme for linux muse-io. You do need to install libbluetooth at the least. “sudo apt-get install libbluetooth3”. Let me know if that works?


#3

I tried but it’s already installed (newest version). If you have a look at that link I posted they refer to the path being incompatible due to the different structure between 32 and 64 bit systems so maybe muse-io is looking in the wrong place? If so how do I make it look in the right place?


#4

from the terminal

libbluetooth3 is already the newest version.
0 to upgrade, 0 to newly install, 0 to remove and 2 not to upgrade.

It didn’t work. I let you (above post) and still no response??


#5

Another week and still no help?


#6

Hi, what version of muse-lab are you running?


#7

[B]glitchpop,[/B] thank for reporting the problem and for the patience. The issue is not trivial as libbluetooth.so can vary a lot between different linux distributions. As MattC said, we are working on better linking scheme for linux.


#8

The current release version from here https://sites.google.com/a/interaxon.ca/muse-developer-site/download/linux-install---sdk-v2-2


#9

got the same problem with the SDK version 2.4.2, give us a shot when there’s an update on this issue


#10

I have a problem with muselab on windows 7. I can start it but I see no graphs even if teh visualisers are properly set. When data has to be shown I see that the part of the screen where vusualisers should be is not updated at all. Can anybody help?


#11

Hi, do you see OSC messages streaming into MuseLab in the OSC panel?


#12

On linux I have found that you will need to install this package to get MuseLab working:

sudo apt-get install libxtst6:i386


#13

For muse-io, if you’re running ubuntu, i found that downloading the 32 bit version of libbluetooth3 was required: http://www.ubuntuupdates.org/package/core/precise/main/base/libbluetooth3

Download the 32 bit deb package. You’ll then need to extract the libbluetooth.so.3.11.5 file into the Muse directory (the directory where the muse SDK was installed). And rename the libbluetooth.so.3.11.5 file to libbluetooth.so.3


#14

Thanks RickyD. I receive messages, I see them. Then I created visualisers but I do not see any graphics.


#15

I wonder. How can I know if I do not mis something in muselab. Some library etc? Instead of visualisers this part of screeen gets transparent, I see the content of other windows and there is no refresh. How do the visualisers work on windows? DirectX


#16

I still don’t have the Muse working many months after purchase. The downloads page now says a 64 bit install will be released soon. I’m on Ubuntu 64 bit. When will it be released please?


#17

maybe in another year or so :confused:

see http://forum.choosemuse.com/forum/main-forum/3709-has-muse-abandoned-calm-devlopment

they are rebuilding calm and considering they appear to be a small team, supporting external developers is their lowest priority and have a closed-source approach, they wouldn’t have the capacity to assign to it and no-one else can help.

32bit SDK when most people are using x64 and no mobile APIs? i think by the time they sort this out we will have much better hardware options.


#18

An SDK update will be released in January or February that will include 64bit Linux support and native libraries for iOS/Android.


#19

150/5000
I can not get the result by Windows 10. Contact us for bluetooth is. Launch io - o receive the error. Launch MuseLab, exhibit port 5000 and nothing. No result. What to do then?


#20

I am on Ubuntu 16.04 64bit

I solved all my library issues by doing the following:

apt-cache search {missing library name, the one that is the most specific, usually with .so.1 or other number between 1 and 9}

sudo apt install {library name}:i1386 the :i386 is important it sets the architecture to the 32 bit version of the libaries, which you don’t have installed, but are being referenced.

Hope this helps someone in the future.