LibMuse Android 1.2.0 minSdkVersion


#1

I noticed in the new 1.2.0 android example you have increased minSdkVersion from 11 to 19.
Is this a requirement of the new libs, or just of the example app?

It seems to compile just fine if I keep my min version on 11, but I don’t have any physical devices to test on to make sure.


#2

It’s just for the example app.
The biggest part of libmuse is crossplatform. It uses C++ and Android NDK (in case of Android). The minimum SDK requirement for libmuseandroid.jar is 9. With the old SDK (< 14) bluetooth connection may take a bit longer, but everything will work.