Muse Direct and Muse Player failure



I recorded some data using Muse Direct on Windows 10 and save it as .muse but now I’m having problems converting my .muse files into .mat to use them in Matlab.

I’ve tried the following command: muse-player -f file.muse -M file.mat

But it gives the error below in my command prompt:

Does someone know what’s going on?


I’ve already tried also the solution @Enigma644 provided in Muse file editing

Command line: muse-player.exe -q -v -f input.muse -O temp.txt

But it gives a similar error:


If the files were recorded with Muse Direct 0.19.0 or lower, then this issue appears if the timezone of the computer contains characters outside of the English ASCII range [A-Z,a-z]. This has been fixed in Muse Direct 0.19.1 (current version as of this post) so it should not be an issue in the future.

To fix the problem, you can try the following workaround. You will need a binary hex editor. I use Notepad++, but any hex editor should work.


  1. Make a copy of your file before attempting this workaround. That way if anything goes wrong in the following steps, you will still have your data.

  2. Open the .muse file in your hex editor. It will be a binary file so you won’t be able to read most of it, but some text should be visible.

  3. Locate the timezone near the top of the file. Replace any non english characters with english characters or ‘_’. Do not delete any characters without replacing them with another character. The length of the timezone must remain the same or the file will not convert.

  4. Save the .muse file. The file size should be exactly the same as your copy from step 1.

You should now be able to convert the file.

Hope that helps.


Thank you for your response,

Sadly my Muse Direct, the one I used to record the data, is 0.19.1

Do you think there could be another cause for the problem? Or do you recommend to still check for any non english character?


I have just noticed that even though Muse Direct is 0.19.1 the file once opened on Notepad++ states that it was recorded on 0.19.0.

Thank you for your reply @cbillard,