Muse-io and Linux SDK don't work?


#1

It seems that muse-io in Linux SDK requires specific Linux distribution or libraries to work. First, the program is 32bit (but I guess they did it for backwards compatibility) which might be a small problem in 64bit environment as you need multilib environment [no problem].

But the bigger problem seems to be that it links to older/newer libraries. Executing “muse-io” gives following error messages (after installing bluez and configuring ld.so.conf and enabling multilib (32bit/64bit) etc. support):

[B]./muse-io: /usr/lib/libstdc++.so.6: version GLIBCXX_3.4.15' not found (required by ./muse-io) ./muse-io: /lib/libc.so.6: versionGLIBC_2.15’ not found (required by ./muse-io)
./muse-io: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15’ not found (required by liblsl.so)[/B]

So the question seems to be why not they don’t use [B]"-static"[/B] linkage for most of the libraries instead so that you do not get so many problems trying to get library dependencies just right. Or if it is because of legal problems? At least ALSO distribute binaries that are also statically linked so things are likely to work correctly and you can still replace libraries with updated or modified libraries if you really want to.

Or if -static linkage fails, try to use something more sophisticated:http://www.magicermine.com/products…ure_comparison.

[I]If anyone knows easy solution to this problem, please let me know. Installing specific older/newer libraries manually seems to be rather complicated.[/I]

[B]System:[/B][I] CentOS 6.
Linux 2.6.32-042stab083.2 #1 SMP Fri Nov 8 18:08:40 MSK 2013 x86_64 x86_64 x86_64 GNU/Linux[/I]

[B]yum list libstdc++[/B]
Installed Packages
libstdc++.i686 4.4.7-4.el6 @base
libstdc++.x86_64 4.4.7-4.el6 @base

[B]yum list glibc[/B]
Installed Packages
glibc.i686 2.12-1.132.el6_5.2 @updates
glibc.x86_64 2.12-1.132.el6_5.2 @updates


#2

I’ve hit a similar problem.
Linux Mint 17
Linux computername 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:11:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

I can provide additional troubleshooting information as needed.


#3

Yea, ok so we will need to rebuild the dependencies with static linkage. Working on 64bit builds for linux and windows too. Thanks for the patience and help!


#4

I just picked up a Muse for some integration testing. I’ve also hit the static vs. dynamic dependency issue. Has there been an update since this last post in August?

Thanks,

Jeff


#5

I’ve just tried the latest muse-io and hit the same problem - nearly a year after the last post in this thread. Is this problem being worked?

(Why can’t we just download the source so that we can do configure/make/make install (or something similar) ourselves? That’s what we do with any other linux application :wink: )


#6

same here, bumping this thread.