Muse-io Error


#1

Hi, I just received my 2014 Muse.
It pairs correctly, when I try to use muse-io I got this error :

./muse-io --DEVICE Muse-92FB
dyld: Library not loaded: /usr/local/lib/liblo.7.dylib
Referenced from: /Applications/Muse/./muse-io
Reason: image not found
Trace/BPT trap: 5

Do you have any clue?
Thank you.


#2

This can occur if you are running muse-io from a shell other than bash.

When the research tools are installed, two lines are added to the .bashrc file:
export PATH="$PATH:/Applications/Muse"
export DYLD_FALLBACK_LIBRARY_PATH="$DYLD_FALLBACK_LIBRARY_PATH:/Applications/Muse"

If your script is using a different shell (tcsh, csh, zsh, etc.) the .bashrc file will not be loaded and muse-io may not be able to locate liblo.7.dylib. If you add similar lines to the .rc file for the shell you are using, that should resolve the problem.


#3

Hi Cbillard,i am using the default terminal.
When I type echo $SHELL, it says im using bash.
In the .bashrc, there are this two lines :
export PATH="$PATH:/Applications/Muse"
export DYLD_FALLBACK_LIBRARY_PATH="$DYLD_FALLBACK_LIBRARY_PATH:/Applications/Muse"
I had to copy them to .bash_profile: I dont know why.
But, now, muse-io could start! :slight_smile:
Thanks for your help.
have a great Day.