Muse-Lab, Muse-Player Muse-IO & liblo Clarifications


#1

Hello Everyone,

I wanted to clarify some problems I am having that do not match up with whats in the developer directories and sorry if they are repetitive to previous posts but I read through all and something gets fixed more problems emerge.

I ran the code for the server dump and works fine. I can see the data stream. This code imports liblo…but when I try to run muse-player it says there is no liblo. I am a little confused about this. I am wondering if it has anything to do with my path? Below is my path for .bash_profile. I am a little dry as it has been a while I’ve worked on the terminal. Also more background, I installed everything through brew such as python, mathplotlib, pyliblo, liblo, etc

export PATH=/usr/local/bin:$PATH
export PATH="/usr/local/bin:/usr/local/sbin:~/bin:$PATH"

export PATH=/usr/local/share/python:$PATH

PATH="$PATH:/Applications/Muse"
export C_INCLUDE_PATH=/usr/include
export LIBRARY_PATH=/usr/lib
export DYLD_LIBRARY_PATH="$DYLD_LIBRARY_PATH:/Applications/Muse"

export PYTHONPATH=/usr/local/lib/python:$PYTHONPATH

Regarding the Muse-lab when I place the port to open up I only see a couple incoming messages:

Muse/acc
muse/batt
muse/config
muse/drlref
muse/eeg
muse/quantization

I am wondering why I dont see the muse/elements/apha,beta, delta, etc. or the FFTs. Is this due to how I run “muse-io --osc osc.udp://localhost:5001,osc.udp://localhost:5002”? As I mentioned before I am rusty and getting back on track with this. Any help would be grateful and thanks in advance!


#2

Hi chiaischi,

What version of the SDK are you using?

By the sounds of it, you’re trying to install the various dependencies for an older version manually. Now all you should have to do is uninstall what you’re currently running and then download the standalone installer for the latest version.

The problem you’re having with pyliblo could be that you have more than one version of Python installed on your machine, and that you are using one for the Getting Started example, and another one for MusePlayer. MusePlayer uses the Python at /usr/bin/python, whereas it looks like your .bash_profile is pointing PYTHONPATH to /usr/local/lib/python. Using the latest version of the SDK is the fastest workaround for this, as it will make sure MusePlayer has everything it needs to run properly independently of however you have Python configured on your machine.

The fact that you’re not seeing the /muse/elements data given that MuseIO command makes me think that you are using an older version of MuseIO. For old versions of MuseIO, you need to add the --dsp flag to get /muse/elements data. However, we strongly recommend to use the latest SDK instead, where --dsp is enabled by default, among other things. Using the new SDK should not break anything you have already built, so upgrading isn’t risky.


#3

Hi Tom,

Thank you for the help as I had a very old version and I did as you instructed and now I can see all the muse/elements data provided. I fixed my path and I think it is solved as it goes through but with errors because of my parameters not input correctly. I don’t think I am understanding how to extract the data to an CSV file.

I am doing the following:

$ muse-player -l -C filenname

Muse Player 1.6.0
Input:
tcp:5000

  • OSC port: tcp:5000 (Hit Control-C to stop)

Output:

  • CSV file: filenname

But it is doing nothing so I do ctrl C to stop it. Could you please explain more on how to properly do this.

Many thanks!


#4

You need to tell muse-player to use UDP, not TCP (which is the default) because you told muse-io to send using UDP, e.g.

muse-player -l udp:5000 -C myFile.csv

#5

Got it! I recorded some data and I am going through the documentation to understand it. I might need help later but first let me tackle.

Thank you for everything!