Muse Marker Does not Appear When Replaying


#1

Hi,
I am recording a test session with different tasks, which are indicated on the EEG data by markers at the start point. However, when I’m replaying the recorded session, drawn markers are not shown and I cannot see when the tasks had been started. May I ask what should I do? Or if there is a specific thing I have to do to get the saved markers shown when replaying the recorded data?

Thanks!


#2

Hi again,
Sorry for posting again. But I really need to fix this marker problem soon. Because I cannot start running the tests for my research without them and am running out of time now. Would any one help me with any solution for this problem please?

Thanks a lot!


#3

Hi Donia,

How exactly are you adding the markers when you’re recording?


#4

Hi,
Thank you for responding.
First I start the recording, then I use the markers section and press the mark button. They are shown on the screen at that time, but when replaying the recorded session they are not in there.


#5

Hi Donia,

One thing that you need to get the markers to plot again is your Muselab needs to have the same marker names and settings when replaying as it did when you recorded. So if you renamed your marker to “Juggling” and changed it to have a start and an end when you were making your recording. Then when you’re replaying that recording you need to change your marker to have the same name and expect and start and end time.

Easiest way to ensure this is by saving the configuration used for the recording and reloading it before trying to replay it in Muselab.

Let us know if that makes sense or continues to not work.

Hope that helps


#6

Hi Farough,
Thank you for responding.
I did what you said and first saved the configuration and reloaded it before replaying the recorded file in Muselab, but still markers are not plotted in the replay mode. Is there any other thing that I should do? Or any thing else that can be tried?

Thank you,


#7

Hi Donia,

It appears that you have discovered an issue with Muselab that we didn’t see before. I tested it out myself and I see the problem, but unfortunately we do not have a solution for it ready at this time.

In the mean time you can see the marker times in Matlab or a csv file you can create using Muse-player to write to a file.

On the plus side, it looks like once we do have a release with the fix your recorded file(s) now will work as intended and you could replay it back into Muse-lab and get the markers showing properly.

I apologize for the inconvenience, but feel free to ask more about writing the events to a file if you think it will be useful for your application. We will work on fixing this issue in the future thanks to your feedback, very much appreciated.


#8

Hi,

Thank you for the response,

Oh, ok then. So may I ask if I can replay or display a recorded file that is saved in matlab type?

Plus, may you explain what are the coloumns and written data in csv and matlab?
For CSV file, I know the first two coloumns are time (I guess in seconds, yes?) and description of the following coloumns. But I don’t know what the remaining coloumns that numbers are written in them are. Also, I couldn’t find any row in the second coloumn that was refering to markers. May I ask what should I search in the CSV file for finding markers data?

Moreover, when I tried to convert a file to matlab format, at first when I typed ‘.mat’ in the command line for the output file (as it was written in the museplayer section on the website), it saved the file as ‘Microsoft Access Table’. Then when I saved it as ‘.m’ a matlab code was saved, but it’s a huge file (43000 kb) that when when tried opening the file, got this error that: “There is not enough memory to open test.m file in the editor”. May I ask what can I do now?

Thank you so much!
Donia


#9

Hi Donia,

Matlab is a program which is used in research and mathematics. You can do a lot of things like streaming of matlab content over OSC, but it’s an expensive tool that is not easily accessible or necessary if you are just looking to check your data.

The first column of the csv is the timestamp since 1970 January 1st and 12:00am down to the microsecond. The point is to be able to know exactly when the data was recorded.
The second column is the path, this is used to describe the type of data outlined here:
https://sites.google.com/a/interaxon.ca/muse-developer-site/museio/osc-paths/3-2-0

The following columns are related to the content of that path type. ie if it’s /muse/eeg, the next 4 columns will be the left ear, left forehead, right forehead and right ear in microvolts.

For the sake of markers, you can expect to find Markers under the path /muse/annotation the following columns indicating the marker name, type and type information. There will be an annotation for both the start and stop of your markers.

Regarding the naming of the extension of your file. Extensions are interpreted by your operating system. So the OS will determine what program to use to read a file based on the extension your write. Regardless of what extension you put on the Matlab file it will be a Matlab binary file which you can only read with Matlab or an hdf5 binary interpreter, Python can read hdf5 files, for example.

The CSV and Matlab options are primarily for viewing data offline opposed to live stream. If you’re really keen to get the live stream for replaying your existing files you could make a fairly simple Python script which could receive your replaying file before Muselab and convert the marker annotations back into Marker messages to get them to plot properly. The script would be fairly simple, but if you’re not familiar with writing Python or setting up a development environment for OSC, you will have some issues getting this set up.

Hope that helps, sorry we don’t have a better solution for you at the moment.


#10

Aha, ok. Thank you Farough.

Yes, I do have access to MATLAB.
Thanks for the instructions. I think it will help.

Best,
Donia