Muse Monitor, and OSC

Hi all,

So I am trying to get my Muse 2016 headband to stream OSC into Processing or TouchDesigner. No luck. Here are the steps I am following:

Turn on Muse. Turn on Muse Monitor. Set a port. Check for correct IP. Start Streaming.
I open the port in Muse Lab. I can see the data coming through. I set up an outgoing port on Muse Lab and check off the data I want to forward. I select UDP.
Then I try to use Processing OSC or TouchDesigner OSCin, but Muse OSC is not showing up at all.

I have been able to get other OSC data into Processing and TouchDesigner so I do not know what the problem is. Please assist.

Your local firewall might be blocking the traffic. Have you tried temporarily disabling it?

Why are you looping the data through Muse Lab?
You could try streaming direct to any app you like from Muse Monitor.

Yes, I turned off my firewall during the entire process. I also tried streaming from the app itself.

Are you sure Processing / Touch Designer are set to receive UDP, not TCP?

I’ve been able to receive Muse Monitors OSC data in Processing, …and Muse Lab itself I’m pretty sure is written in Processing… so it’s probably something misconfigured somewhere in your setup, but I’m really not sure what, sorry!

I’m using UDP.
Do you have an example code for the muse successfully running in processing that I can try?

I don’t sorry. I had processing installed a few years back when I re-wrote the MusePlayer code to fix an Interaxon bug, but I have re-installed my computer since then!

I got it to work for processing. PM and I can send what code I came up with if you are still having problems.

Hi, just wondering if you had any more success since? Would appreciate seeing code too if you don’t mind sharing. Thanks!