Muse monitor OSC streming

musemonitor

#1

Hi,
I have a Muse headset 2016 and I bought the Muse monitor app.

I am trying to use the streaming to the MuseLab, but unfortunately it is not working.

I tried different things and searched on the forum (How to use Muse Monitor OSC streaming? especially).

I loaded the JSON configuration file suggested there, I can see it opened port 5000 and I can see the graph, but nothing is coming in.

I am sure I have setup the IP and port correctly in the app, if I try a tcpdump on port 5000 I see the UDP packets coming in.

Any idea what I could do to trobuleshoot the problem?
Thanks!


#2

There was another user who had a linux graphic driver issue with Muse Lab, where it was running ok, but nothing came up on the screen. What OS are you running?


#3

I am using Ubuntu.
Later on I can give you all the specs…

If I remember correctly when I had the Muse 2014 I have been able to connect it to muse io and muse lab.

The headset broke and I have been sent the 2016. I was trying to stream osc as workaround for muse io not working


#4

First test if Muse Lab is working properly. Record a session to “.Muse” format with Muse Monitor, then play that back locally with Muse Player to Muse Lab.

If that works, then you likely have a networking issue.

Temporarily turn off all firewalls. Check your mobile device is on the same Wifi/subnet. Check UDP traffic is allowed on your router.


#5

Hi Enigma,
I will try tonight with the .Muse file, didn’t think about it.

Regarding networking, I doubt that could be the issue?

If I run tcpdump on port 5000 on my Ubuntu machine I see the packets coming in…


#6

If you see the packets, then it’s likely a rendering issue with Muse Lab.

Do you see anything in the “Incoming Messages” list in Muse Lab?
You should see a list of OSC addresses each with a data rate and sender IP.

Also confirm that “5000” is listed in the “Opened Ports” drop down.


#7

Hi Enigma,
I am trying again now and I noticed something I didn’t notice yesterday.

If I launch the MuseLab from the terminal, I see in the terminal:

"### [2017/11/21 19:1:15] PROCESS @ OscP5 stopped.

[2017/11/21 19:1:15] PROCESS @ UdpClient.openSocket udp socket initialized.

[2017/11/21 19:1:16] PROCESS @ UdpServer.start() new Unicast DatagramSocket created @ port 5000

[2017/11/21 19:1:16] PROCESS @ UdpServer.run() UdpServer is running @ 5000

[2017/11/21 19:1:16] INFO @ OscP5 is running. you (127.0.1.1) are listening @ port 5000

"

while of course the streaming is directed to my real IP.

In my ifconfig I can see eth0 configured properly with the IP 192.168.0.x and I don’t see anywhere the 127.0.1.1

(I have in the lo 127.0.0.1)

Again running tcpdump the packets are coming in, for example:

19:02:00.157007 IP 192.168.0.199.37035 > hostname.5000: UDP, length 60

Why is MuseLab not getting the right IP?
Any suggestions around that?

I recorded a .Muse now and I will try with the Player in the meanwhile


#8

And I just tried to play from the Muse player, it works…
so I guess the issue is why MuseLab is taking 127.0.1.1 as address…


#9

127.0.0.1 is local the loopback IP… but you said 127.0.1.1 above; was that a typo?
When you’re testing Muse Player try each of these options:
-s osc.udp://localhost:5000
-s osc.udp://127.0.0.1:5000
-s osc.udp://192.168.0.199:5000 <-- Assuming this is your local IP from ifconfig.

All three should work.


#10

Hi Enigma,
that was not a typo.

The Muse Player is working, if I stream from Muse Player to Muse Lab everything is fine (because it’s localhost).

The problem is to stream from MuseMonitor to MuseLab to have real time data.

MuseMonitor streams to the correct IP in the lan 192.168.0.199 UDP port 500.
I see the packets coming in running tcpdump port 5000 on my Linux machine.
MuseLab doesn’t show anything, doesn’t see anything in the Incoming Messages and it shows me that it is listening on the wrong address (127.0.1.1). I do not have this address anywhere in the network config, so I have no idea where it takes it from.

[2017/11/21 19:1:16] INFO @ OscP5 is running. you (127.0.1.1) are listening @ port 5000

Is there any way to start MuseLab on a different IP address? A switch from command line?
Or to find out why it listens on the wrong ip.

Thank you!

UPDATE

I will try something tonight, I checked on ubuntu forums


For some reason apparently MuseLab doesn’t detect the network, so I will force my IP in the network config of ubuntu and see if it solves!


#11

Looks like it might be a bug in the oscP5 or netP5 library.
Someone is having a similar issue on a raspberry pi: https://forum.processing.org/two/discussion/14738/processing-on-raspberry-pi-thinks-its-ip-address-is-127-0-1-1

@Jack Any chance you can put the source to Muse Lab in the Interaxon bitbucket so we can debug/fix this?


#12

I finally solved it!!!

I set manually a static IP address in the /etc/hosts and MuseLab started to take the right IP.
I also run a "sudo ufw allow 5000/udp"
and finally I started to receive everything!

I am sorry, my lack of knowledge about networking made me think that if I was seeing the packets in tcpdump it meant the computer was allowing them.
But I then realized that tcpdump is before the firewall… so this last command was needed!

Regarding the network settings in Ubuntu, it would be of course bettereto be able to leave the default config… but I am not complaining, I will just have to be careful if the IP changes.

I hope my suffering can help someone else facing the same problem!

Thanks a lot Enigma for your help and support… if you’d like to troubleshoot further if we get the code in bitbucket I am of course available!

Thanks!


#13

Awesome, glad you sorted it :slight_smile: