Muse-player stuck from .muse to .mat conversion


#1

Hi,
I am trying to a convert a .muse file to mat using muse-player. The file is 717.4 secs long so it is by far under 32 minutes (I have read that the current version can’t convert files of 32 minutes, or more). When muse-player is at “717.4 secs Sending Data” it sticks (I have tried it several times). I waiting for about 3 hours and nothing happened. The only thing I noticed is that the .mat file that created at 717.04 secs was getting larger by the time. Also when i interrupt the process and open the .mat it seems that the only missing values are the RAW ones. I tried it on both MAC and PC and I notice the same. To check if the file was corrupted I tried to transmit it over osc.tcp and display it via MuseLab and works fine. I also managed to convert it to .csv but not to .mat

EDIT: I tried to do a conversion with significant smaller file and the same thing happens. I am using the command muse-player -f my_file_name.muse -M mat_file_name.mat . I have to mention that have done some successful conversions in the past. I have no clue what is going on. I am doing the recording via MuseLab in case it matters.

EDIT 2: While using muse-player as an osc listener directly from muselab it exports .mat files normally (but i can’t use markers which is crucial for me), redirecting .muse files from a muse player to another doesn’t work and gives me the aforementioned state (can’t stop it by Ctrl+C and i have to kill the process).

EDIT 3: After a long time of experiments it seems that muse-player fails to convert the .muse file in case osc messages contain --osc-timestamp.

Thanks in Advance


#2

Hi Axlia,

Thanks for the bug report! I believe this is a known issue with MusePlayer. In our next release we should be including a fix for it.


#3

I have the same issue with the .muse to .mat file. Have there been any progress on this front? I currently have the muse 1.8.4 version.
Thanks!