MuseIO doesn't talk to MuseLab


#1

Hi

I’m a newbie so this is probably something simple.

I can get muse to open in MuseIO, but I don’t see a list of data there, only
Device match pattern: muse
Connecting to paired device “Muse”: open!
Connected.

================== Muse Status ==================
Muse Hardware: 17.0.0
Muse Firmware: 7.2.4
Muse Firmware type: Consumer
Muse Bootloader: 7.2.4
Build No: 44
BT Mac Address: 0006666C0E34
BT Firmware: Ver 5.45 IAP 10
Serial: 1170-4JJA-0E34
Preset: 14
Filters Enabled: true
- Notch Frequency: 60Hz
Accelerometer Enabled: true
EEG Sample Frequency: 3520Hz
EEG Output Frequency: 220Hz
EEG Samples Bitwidth: 10
EEG Channel Count: 4
EEG Channel Layout: TP9 FP1 FP2 TP10
Downsampling: 16
Output Mode: SEROUT_COMPRESS

bits/second: [B]8071[/B] receiving at: [B]220.26Hz [/B] dropped samples: [B]0[/B]
Battery: [B][================== ]+ 90%[/B] voltage: [B]4.04mV[/B]
Noise: [ [B]0.8% 0.8% 0.8% 0.8% [/B] ]

And nothing shows up in Muselab either.

When I type

muse-player -l 5000 -D

Into terminal I get loads of stuff coming through, but again, nothing in Muselab.

Can anyone help me get data into Muselab please?

Another problem is that it seems to connected for a minute or two and then lose connection… any ideas?

Thanks


#2

Hi Skramble,

How are you setting up MuseLab? Be sure to open port 5000 and correctly select either UDP or TCP depending on your command to MuseIO. From the output you pasted there I would guess that you are using UDP, in which case you need to select that when you open the port in MuseLab. By default it will use TCP.

Also, make sure that there aren’t any other programs listening on port 5000. For instance, you cannot run both MusePlayer and MuseLab listening on the same port.

For the connection issues, please try updating your firmware. Download the Muse app onto your mobile device (the absolute latest firmware is available only through the iOS app at this time, but the Android app will also provide a slightly older update which still includes the fix for your issue), pair your Muse, and it should automatically prompt you to update.

Hope that helps!