MuseLab visualizations not appearing


#1

After many months y problem is not solved. muse-io works, I see UDP packeges coming, but in muse-lab the visualization doesnt work. I see no graph in spite I did everything as in the tutorial. I can see data in MATLAB or in muse-sharp, but not in muse-lab. Can anybody help?


#2

Hi Marko,

Can you provide some more information about your problem?

Namely operating system, MuseLab version, MuseIO version, and the command to MuseIO you’re using.

Do you see the messages coming into MuseLab in the list of incoming OSC paths? Also, please make sure that no other programs are listening on the same port as MuseLab.


#3

I am running muse-io on windows 7, 64 bit. the version is: 3.6.4 (Build-15 Dec 22 2014 17:07:55)

this is my command line:

muse-io --50hz --osc osc.udp://localhost:5001

muse lab is set to UDP port 5001, I see incoming messages in OSC paths. There is no other program listening.

So basically, I receive messages but there is no visual representation and the visualisers are created as in the manual. When the visualizers are created that part of the main window (the right side) is not updated any more. So it seems that muse works but that some graphical part of the muse lab does not.


#4

What make/model of computer and graphics card are you using? It may be that your machine’s graphics card has a problem with MuseLab. Your graphics card needs to support OpenGL.

To see if this is the case, open a Command Prompt in the Muse application directory and run MuseLab with this command:

java --jar muselab.jar

That way you should be able to see if it is throwing any errors when you try to plot data. Please copy and paste the output that’s printed to the prompt here.


#5

thanks Tom, this could really be the case:
What should I do? Is this an old version of JAVA that I have here.

C:\Program Files (x86)\Muse>java --jar muselab.jar
Unrecognized option: --jar
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

but as you see , Java is installed

C:\Program Files (x86)\Muse>java
Usage: java [-options] class [args…]
(to execute a class)
or java [-options] -jar jarfile [args…]
(to execute a jar file)
where options include:
-d32 use a 32-bit data model if available


#6

I think java in windows just take one “-” before arguments, not two,
also the MuseLab .jar file has a dash in its name, the .EXE no, so try:

java -jar muse-lab.jar
or
java -jar muse-lab.jar -d32

I have seen this behaviour in more than one computer, and some other users have said the same

  • in my laptop (windows 7 HP SP1 32 bit) it does not work (maybe its graphics chip does not support OpenGL)
  • but in my desktop I have dual boot (windows 7 Ultimate 32bits and windows 7 - HP 64 bits) - so, the same graphics chip and Nvidea drivers installed are the same
    muse-lab works fine in windows 7 - 32 but not in windows 7 - 64b. The java portion of the screen just shows a ligh gray background … if I minimize muse-lab and maximize it again, the java portion (the big right side) shows the back of my screen, whatever is there.

The left portion (non java) works as expected: after connections all signals coming from muse, and after creating a visualization all signals available, but no graphics is shown after selection of any signal.

BTW, MuseLab is the only java app that does not work well in my computers.


#7

Thanks Eduardo.

But, how can I know that my gr. card doesnt support OpenGL?
And what to do in that case?

has anybody worked with windows 7 - 64b, that is what I have.


#8

i tried java -jar muse-lab.jar and muse lab was normally started


#9

Marko,

When you have MuseLab running in this way and you try to plot some data, what information is printed to the Command Prompt window?


#10

this happens:
so probably graphic card problem. but what to do?

    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

[B] at java.awt.EventDispatchThread.run(Unknown Source)
Exception in thread “AWT-EventQueue-0” java.lang.RuntimeException: Number of tex
ture units not supported by this hardware (or driver) Read http://wiki.processin
g.org/w/OpenGL_Issues for help.
at processing.opengl.PGL.bindTexture(PGL.java:2593)
at processing.opengl.PGL.createFBOLayer(PGL.java:542)
at processing.opengl.PGL.beginDraw(PGL.java:666)
at processing.opengl.PJOGL.beginDraw(PJOGL.java:593)[/B]
at processing.opengl.PGraphicsOpenGL.beginOnscreenDraw(PGraphicsOpenGL.j
ava:6187)
at processing.opengl.PGraphicsOpenGL.beginDraw(PGraphicsOpenGL.java:1635
)
at processing.core.PApplet.handleDraw(PApplet.java:2244)
at com.ix.processing.Processing.handleDraw(Processing.java:191)
at processing.opengl.PJOGL$PGLListener.display(PJOGL.java:810)
at jogamp.opengl.GLDrawableHelper.displayImpl(GLDrawableHelper.java:649)

    at jogamp.opengl.GLDrawableHelper.display(GLDrawableHelper.java:633)
    at javax.media.opengl.awt.GLCanvas$9.run(GLCanvas.java:1271)
    at jogamp.opengl.GLDrawableHelper.invokeGLImpl(GLDrawableHelper.java:110

#11

The reference that the error message links to is quite helpful: https://github.com/processing/processing/wiki/OpenGL-Issues

Have you looked into updating your graphics card’s drivers?


#12

I solved the problem by updating the driver. Thanks Tom


#13

I have a very similar problem (grey area without any plots instead of black area with plots), checked video drivers, checked ports… I’m using TCP on 5000, W7 64b, updated NVidia GeForce drivers… still the grey background.


#14

I’m having a similiar problem. I’m using a Macbook Pro.

The problem I have is that when I select Visualizer to add a visualization, the only open I get is “Hot Keys”, there is no option to actually create a visualization.


#15

I’ve tried the suggestions above to update my video drivers… my window where the graphics should be is flickering, not like the above problem where his was gray. Any other suggestions? I too am getting the streaming data, just not the visual graphs.


#16

#17

Hi
It looks like I have the same problem
I recently got my new Muse device
I am using windows 10
the Osc seems to generate raw data, but I’m still not able to visualize things since the visualization area is gray.
Do you guys have any advices please?
Thanks for your help