Problem Converting .Muse file to .Mat/.CSV file


#1

I have been trying to get my .muse file to convert either a .mat file or a .csv file so that I could be able to see the data and proceed in analyzing it. I would prefer to have a Matlab file but either one would be ok. Whenever I try to convert the file, I get “IOError: [Errno 13] Permission denied: ‘muse.mat’” and when I try to convert to a .csv file it says “Error: Unable to open file at muse.csv”. I have been trying to get this to work for way too long now, I even uninstalled and re-downloaded everything and it says the same thing at the end. Any feedback as to how to fix this problem would be greatly appreciated.


#2

Hi there abar,

I have a few questions for you to narrow things down.

  1. What operating system and version are you using?

  2. What version of the SDK and Muse-Player are you using?

  3. Can you copy-and-paste the command you are trying here?

  4. What is the path to the file that you want to convert, and from where on your system are you running the muse-player command?

Regarding the “Permission denied” message you are encountering, have you tried running the command with root privileges? On Windows this would mean running the Command Prompt as administrator, on Linux and Mac you would run the command itself with as root like:

sudo muse-player -f inputFile.muse -M outputFile.mat

#3

If you are running on Windows, maybe problems with administrator privileges on the directory where you’re trying to save the files (system folders), for example, running muse-player directly in \program files\muse

Have you tryed opening the command prompt as adminitrator (right-click command-prompt and click on “run as administrator”), or create a shortcut for it in your desktop - right click it, and in “properties -> advanced” check “run as administrator” box - then you can allways start from this icon.

You may also create another directory (e.g. C:\MuseRecordings) where all users can create files.
Running from this derectory, remember that c:\program files,muse must be in your system’s path.

HTH, Eduardo.


#4

Hello Tom,

To answer your questions:

  1. I have windows 8
  2. I have Muse SDK version 2.4.2
  3. I have a snip of what my command looks like.
  4. I have the file in the Muse folder that is made when the SDK is downloaded. I havent tried running the command prompt as administrator, so I’ll try that next.

#5

Hi Tom,

I have my code for muse-player like this(running on windows 8)
C:\Program Files (x86)\Muse>muse-player.py –f C:\Users\Desktop\MuseLabRecordings\muselab_recording12.muse –M C:\Users\Desktop\MuseLabRecordings\muselab_recording12.csv
but whether i give the out file extension or not it is by default generating an out file with .mat
like muselab_recording12.csv.mat
which is also in binary format what is the solution for this…


#6

Hi goutami,

So, you got muse-player working now ? Great !

What tells muse-player what type of file to generate is the parameter, not the file extension.

If you want a .CSV file (pure text), use parameter -C (-M is for Matlab wich is binary), like this:

muse-player.py -f myfile.muse -C mytextfile.CSV


#7

Hi Eduado,

Thank you,
muse-player was telling
Muse-Player 1.4.2
Input:

  • Muse file<s>: [my input file path]
    out put:
  • Mat lab output file: my file.csv
    Playback Time: 85.0s : Sending Data

Now i am geeting the data in text format.


#8

Sorry, getting like
1415220858.379000, /muse/acc, 74.218864, 972.6578, 226.56285
1415220858.513000, /muse/eeg, 814.26526, 825.78015, 825.78015, 825.78015
1415220858.513000, /muse/eeg/quantization, 1, 1, 1, 1
1415220858.513000, /muse/eeg, 815.9103, 822.4902, 825.78015, 832.36005
1415220858.513000, /muse/eeg, 815.9103, 825.78015, 822.4902, 820.8452


#9

Hi Eduardo,
​Sorry, I apologize for my typo errors.


#10

Hello Friends,
Try LongPathTool for resolving error like path to the file is too long…