Problem with EEGlab analysis of Muse data


#1

Hi guys. I am having trouble with translating data in to MATLAB. I’m converting the muse files to csv format and as I look in to Channel data scroll on EEGlab, it gives me weird peaks (attached in image). Moreover, it is not also showing data from all channels, it just shows 2 channels, while muse shows all electrodes connected on muse direct. Can someone please help identifying the problem?


#2

Do you have NaN data on TP10? Check the raw data file.


#3

Hey Thanks for the reply. I have NaN data for notch filtered EEG. I am attaching the pictures for your review. First one is the file converted to csv and other 4 converted to .mat. I generally select alpha,beta,theta,delta absolute and in the signal group options I check alpha, beta, theta & delta absolute and notch filtered EEG. However, when I open it in MATLAB, it doesn’t show the “elements” folder. Is there something wrong with data collection or processing? What can I do if I just want to observe the TP9, FP1, FP2, TP10 showing spontaneous activity (not specifically alpha). Thanks a lot for your time.


#4


#5


#6


#7


#8

From the screenshot you’ve only got NaN showing on the 5th and 6th channels, which assuming you have the MU-01 are the Aux channels which you’re likely not using, so that should be ok.

In the EEGLab screenshot, most of the data looks ok, so you’d need to scroll down the entire column to check the source data. Can you upload the CSV data, so i can check?

What are you using to collect the data? Muse-IO?


#9

Hey thanks a lot. I am using muse direct to collect data. I don’t find the option to uplaod files here (except pictures). Can you please send the email on which I can share csv data? Also please let me know what do I need to check for collecting data (alpha, beta,theta,delta absolute) or Notch filtered EEG or raw eeg? Also why am I not able to see the “elements” folder when I convert my files to .mat?


#10

Upload it online to something like https://files.fm/ then everyone on the forum can see/help :slight_smile:

I have a theory that you’ve got bad data being collected from the Muse device. I’ve seen quite a few people with bad data being collected from LG devices, specifically the G6, so it’s that that I wanted to check out.

What are you trying to analyse? You probably want the main brain waves Alpha.

For RAW, Notch filtered means that the results will have the 50Hz or 60Hz power line buzz removed from the results. If you’re not looking at results around those frequencies, then I wouldn’t worry. You only need RAW if you’re doing your own FFTs.


#11

I am uploading my csv files there for review. I am actually using windows 10 updated version for muse data collection. I must mention at this point that these files are generated with eyes open for a minute only. However, the 3D images I am getting out of them show only red in the whole brain. For notch filtering, I am mainly looking at the the time it takes for beta to shift to alpha and then theta wave after sitting silent for around 20 minutes. I am not doing FFTs separately so probably I do not require raw data and must go for notch filtered EEG.

Please see my csv data attached here

Please note that Exp.O2 is eye closed data
MFA-15oct is eye open.


#12

This is a link to the main files.fm site, please add a link to your specific upload


#13

I’m sorry about that. Please find it here


#14

There’s a bunch of places in your data where you’ve got blocks of “nan” showing up, so my best guess is that this is throwing off your analysis software.

nan comes up when there’s a problem transmitting the data over bluetooth, so I’d recommend using a different device to connect to the Muse.

The notch_filtered_eeg data seems to smooth over the nan data, so as a workaround I would use that instead, but as your source data is corrupted, I wouldn’t use this for anything serious. If it’s just an art installation, then you’ll be fine with the notch filtered results.


#15

Hey thanks a lot. I tried a new usb connection. What I see is that there’s a problem with import of .mat data. It doesn’t show “elements” folder as shown in this tutorial https://www.youtube.com/watch?v=YUJ2fax2Sno. What could be the reason that the elements folder is not detected by matlab (please see attached picture?


#16

What’s in IXDATA?


#17

Most of the folders contain empty excel files. Only the acc files (which I think the accelerometer data), the eeg data just has one column. I am attaching the pictures of the folders that have some data. Please have a look.


#18

Can you upload the mat file. I’ve found a free mat file viewer called HDFView


#19

Thank you. I have attached file on the following link. Please have a look. Please let me know what’s wrong with this data. Why can’t I get the proper results.


#20

You’re right, the only data in here that makes sense is the Accelerometer data. There is some eeg data in here, but it’s lost in the mix of the references section with a few bits of other data.

I’m not sure what to suggest sorry!

The only thing I can recommend is that you switch to using Muse Monitor to record your data.

By default Muse Monitor will record to CSV at 1Hz, but you can go to settings and change it to record to .Muse format at the full sampling rate, then you can convert that to MatLab format using Muse-Player quite easily with this command: muse-player.exe -q -v -f inputFile.muse -M outputFile.matlab