Problems with MuseStatsiOS 1.2.1. app


#1

Hi, I’m having a problem connecting to my headset from MuseStatsIos 1.2.1. app. I built the app in the Xcode, started the simulator for iPhone 5s and got this output: 2015-10-08 15:40:56.987 MuseStatsIos [10428:14967943] Error showing Muse picker: Error Domain=EABluetoothAccessoryPickerErrorDomain Code=3 “The operation couldn’t be completed. (EABluetoothAccessoryPickerErrorDomain error 3.)”

When I changed the target and tried to build it on my 5s phone I got the linker error:

linker command failed with exit code 1 (use -v to see invocation)

I am using OS X Yosemite 10.10.4. Prior to running a project I paired the headset, and connected to it, but it disconnected after 10sec on my Mac.

Let me know what can I do to solve those problems.
Thanks,
Jelena


#2

Hi Jelena,

I don’t believe that the simulator can easily access the Bluetooth interface of your Mac. Can you try building and running the project on an actual iOS device?


#3

I’ve changed the build settings [B]Enable Bitcode[/B] to [B]No[/B] and added to [B]Other Link Flags[/B] [B]-lc++[/B]. That solved all the problems and now I can run the example on my iPhone and Simulator. It connects with the headset and works fine. It would be good to add that in the readme file on how to compile the app.


#4

thanks @dumajel, the “-lc++” flag was what i was missing