Recording in research mode but gives me 220Hz sampling rate instead


#1

Hi,

I was trying to get EEG data through command line using the research presets. I used a 2014 headband. After I connected museband with my computer, I gave the command line “muse-io --osc-timestamp --preset AD”. The sampling rate was supposed to be 500 Hz. But when I extracted raw data from the output file and calculated the sampling rate based on my recording time and no. of samples I actually got, I found out that output frequency is 200 Hz instead of 500. I also tried AD, and AE. None of these preset command gave me 500 Hz sampling rate. Can anyone help me out here? Thanks.


#2

Make sure to add the option “–no-dsp” to the command line to get the 500Hz, like so:

muse-io --preset AD --device-search “muse” --no-dsp

This turns off the DSP output and allows you to set other presets besides “14”.

If you dont use that option, and issue a command like this:

muse-io --preset AD --device-search “muse”

You will see a line in the output that reads:

Forcing preset “14” required for DSP input.

What that means is that it switched you back to preset 14 because it was assuming that you wanted the DSP output, which only works with preset 14.