Screen Flickering Problems in Graph Window Pane


#1

I’m using the Muse 2016 Version Headset… along with the Muse_Monitor App as recommended with this version. Thanks to advice here on the forum… along with following the step-by-step Getting Started Documentation on MuseLab… I can tell, I’m streaming the data perfectly fine. But at Step 6 " Add Muse Data Streams to the graph"… my graph area of the monitor simply flickers as when it does upon first loading Muselab. My question is at this step in the process… Does the graph automatically begin to work and display itself? It would appear to me that after you’ve made all the selections, you would click on a “graph” or “plot” button. I’m wondering if my desktop system isn’t meeting certain requirements to run this program. Has anyone had this problem. I’ve changed my screen resolution to every possible setting with no luck. I get no scrolling graph, just a black flickering screen in the graph portion of the window. Any advice?


#2

If you’re using Muse Monitor, all you have to do is load the Muse Monitor - Muse Lab config file. Nothing else needs to be done in Muse Lab.

The config file sets up all the graphs and the receiving port.

When Muse Lab is loaded, there should be no flickering, or graphics glitches at all. If the Muse Lab program is not showing correctly, then I suspect that your problem will be with your local Java installation.

There is an old tutorial video here on youtube where someone loads Muse Lab. This video is of a Mac, but Muse Lab appears exactly the same on a PC. When the app loads, there is no flicker of any kind. This should be how it looks when you load it also.

Perhaps someone from Interaxon can confirm this, but to me it looks like Muse Lab was built in processing and the install folder contains a Java runtime. It’s possible that on your system, your local java is being using rather than the included runtime and this may be messing it up.

I would recommend that you remove and re-install you local Java run time (with the latest version) and then if that doesn’t work, remove and re-install Muse Lab.

If you still get errors after this, then I would give Interaxon tech support a call.


#3

excellent thanks… I’ll do as you suggested including deleting and reinstalling MuseLab… I’ve also checked my system… are you aware if having a 32 bit processor vs a 64 bit processor makes a difference or not? I did watch the video… that helps me to see what should happen. Great advice. For example… I downloaded MatLab but it requires a 64 bit processor to run.


#4

I’ve read older topics concerning this problem… tried some of their solutions… updating my video graphics driver… one also mentioned updating the Java Driver… any help in this area would be great. It’s my last option to try to fix my screen flickering problem. I do see the streaming data fine… just not the visual scrolling graphic yet… I’ll search to see if I can figure out if my java needs updating… just not sure how.