Setting filter, and disabling of filter


#1

I am trying to set MuseIO to the 50Hz filter option by running

$ muse-io --50hz

Which seems to be recognized as the commandline output then says: “Default notch filter will be set for 50Hz regions”, but a few lines further down, when it prints out the == Muse Status ==, it still lists the notch frequency as 60Hz.

Preset: 14
Filters Enabled: true

  • Notch Frequency: 60Hz

Are there other ways of setting the 50/60Hz filter?
And also, how would i be able to disable the filter? So i can compare how the FFT spectrum data looks with/without the 50/60 filter settings.

[Muse Hardware: 15.0.0
Muse Firmware: 7.2.4]


#2

Hi,

That’s strange. That should be the correct way to enabled the 50Hz notch filter. What version of MuseIO are you using?

There is no way to turn the filters off in the current SDK. You can only switch the notch between 50/60Hz. There will be a noticeable difference in both the time domain and spectrum when you switch between notches, depending on which region you are in. When the notch is not being applied to the mains frequency of your region, you will see a spike in the spectrum around that frequency and more noise in the time domain.


#3

Hey Tom,
I am using muse-io 3.6.2 (build-12 Nov 17 2014)
I am currently in Europe and I definitely see a spike around 50hz in the spectrum (fft bin 58*0.86 = 50hz).


#4

What operating system and version are you using?


#5

I also have the same problem. I’m also from Europe and i have win 8.1


#6

This problem was fixed in muse-io 3.6.4 (SDK Release 3.2.2).