Unity 6.0.0 ios iphone 7 build problem


#1

I’ve tried to run latest unity example. When I’ve tried to run exported project from unity I’m getting error below. What could be the cause of the error?

thanks…


#2

Try including the ExternalAccessory and CoreBluetooth frameworks. Normally those frameworks do not need to be explicitly linked on iOS, but the link errors correspond to classes in those frameworks.


#3

Thanks, It solved my problem to build. But in the unity example app I couldn’t connect to the muse even though if I try ios example it works perfectly fine.


#4

Hi,

Make sure you have followed all the steps outlined in our Getting Started guide for Unity. It seems like you got the iOS unity example app running. When you click the refresh button, do you see any Muses listed in the dropdown box? You might have to scroll down a bit before you see it, the scroll view is a bit small. Once you see the muse in the dropdown, select it and then press connect. Let me know where in the process this fails.

Best


#5

Hello Jack,

Yes I’ve tried everything in getting started guide. And tried again now but there is no muse connection with the unity example. I uploaded my project you can check it here.


#6

Hi @mertnesvat,

I did download your iOS project and ran into the problem you described. However, I was not able to reproduce this problem if I generate the iOS project myself. I noticed that pressing the refresh button doesn’t seem to do anything in your iOS project and no muses shows up in the list.

Can you confirm that you performed this step that was outlined in the Getting Started guide: “Click on the Canvas element, then drag SampleApp.cs to the “Missing (Mono Script)” text box in the Inspector view.”

Basically you need to drap the SampleApp.cs file to the box that says Missing (Mono Script), please see attached image.

Another thing is that if you are using a 2014 headband (it should have two charging ports, one on each ear), then you must pair the headband in your iOS bluetooth setting first before you can see it show up in the app list.

If these still doesn’t work for you, can you please let me know the version of Unity, Xcode and iOS device.

Thanks


#7

I can vouch for this fixing the issue


#8

This post was flagged by the community and is temporarily hidden.