Unstable connection El Capitain


#1

Hello,

I am having problems connecting my macbook to muse:

  1. I always have to run the muse-io through terminal in order to pair it
  2. if I disconnect it the computer freezes and I have to force restart it

I have purchased a couple of dongles to try to fix the problem (following some previous threads) but installing the dongle on a mac has proved more than difficult for me. In particular, I followed these instructions http://www.atpeaz.com/using-unsupported-bluetooth-4-0-usb-dongle-with-os-x/ but the vendor id and product id do not appear as described and I am not sure what to do!

The problem is somewhat urgent since I am presenting my meditator musical interface in a few days. Any help would be greatly appreciated!

Michele


#2

Hey Michelez,

What model number and year is your Mac?

  1. That is by design. MuseIO is a command line application. Note that pairing and connecting are two different things. Pairing establishes an agreement between two devices to connect and communicate in the future. But connecting is when the two devices actually start sending data to each other. You pair Muse to your computer with your OS’s Bluetooth menu. You connect to Muse using MuseIO.

  2. I’ll check with our team and get back to you on this one.

Does your Muse have the latest firmware? MuseIO prints out a firmware version when it connects. The latest is 7.8.0 and resolves some Bluetooth issues. If your firmware is out of date it can be updated exclusively through our iOS application. Simply download the app on an iOS device, pair Muse with the device, open the app, and start a session. If your FW is out of date, you will be automatically prompted to update.


#3

Hi Tom,

Thanks for replying to this one as well! (I have two different issues on two laptops). the model is macbook pro mid '14 retina 15 inch (2.5GHz Intel core i7).
I was aware of the firmware issues from other threads: I have downloaded and installed the latest musesdk and assumed that would take care of that? I am only using muse on my laptop no iOS device.
I just checked the firmware: 7.2.5 so no I don’t have the latest firmware. Can I upgrade without having to install the app on iOS device?


#4

You’ll need to use an iOS device to update the firmware. I’m afraid that’s the only way. If you don’t have an iOs device yourself, you may need to borrow one from a friend for a few minutes.


#5

Ok, I can borrow an iPad I do I go about installing it? I have never done it…


#6

Done, Thanks for the help!


#7

The computer still freezes anytime I stop using muse and muse-lab. I have to force restart it… pretty annoying.
Any news about this bug?


#8

Can you describe what you mean by disconnecting it? What exactly do you do that leads to your computer freezing: turn the headband off? Close MuseLab? Stop MuseIO?


#9

pretty much all of the above: if I quit terminal it freezes, if I close muse lab or disconnect from bluetooth it freezes… It takes a few minutes to actually stall but eventually it always does


#10

I have the same issue. Haven’t been able to narrow it down to a single resource-consuming process yet.


#11

Same here. There’s no way to safely quit muse-io. (El Capitan)


#12

It seems to be an El Capitan issue. (Tested on Mavericks without crashes). The only way to quit the process in El Capitan without a system crash is to 1. suspend it by pressing Ctrl+Z in Terminal 2. Get the PID (Look it up in Activity Monitor) 3. Kill it by typing “kill -KILL [the PID number]” in Terminal


#13

Hi Muse developer I Couldn’t create a new topic in the forum. is there any technique issue at the moment?


#14

I’m having the same issue.

Everytime I pair my headband, and then close terminal or MuseLab, Mac Finder stops responding to anything.
So I can’t force quit any programs, restart, shutdown or do anything. The only way to restart is to press the Mac’s power button for 6 seconds and reboot, which I hate to do.

Is there any correct way that I’m supposed to be shutting down MuseLab and disconnecting the headband so that this doesn’t happen?

I’m running muse-lab 1.6.3 Build 17 on OSX El Capitain 10.11


#15

@chris_a’s workaround seems to work for me, but with a few clarifications. First, I see two muse-io processes in Activity Monitor. If I kill the process associated with ~0% CPU / CPU time first, then the system doesn’t crash. It also kills the other process most of the time; if it doesn’t, then I explicitly kill the second process too. The OS does appear to be unresponsive for a few seconds afterwards though… but it resolves shortly thereafter. Just need to be patient. It’s still not ideal, but better than explicitly powering off / on my Mac.


#16

Same issue happens to me as well.

kill PID doesn’t work for me. it still freeze the Mac.

I am planing to retrieve back to Yosemite.


#17

Also having the issue. When using muse-io, upon exit of muse-io, El Capitan becomes unresponsive and requires a hard reset. Not a problem in Yosemite.


#18

I’m using Windows 10 with a Motorola generic usb bluetooth dongle. I was able to pair and connect my Muse according to Windows but when running muse-io I got the same connection error “No paired devices exist with matching name or MAC!” Windows would then prompt me saying that the connection has failed and I should remove the device.

After removing the device from Windows I ran muse-io [B]before[/B] pairing and this time was prompted to connect with the passcode. I made a few wild guesses and found that [B]1234[/B] worked and the device then connected.

This is quite different from the instructions given so I’m not sure why this worked.


#19

Sorry to hear about your issue. We’ve heard a few accounts internally of people have this as well. I’ve created a ticket internally on our backlog for our developers to take a look at this.